Cargo behind proxy (windows)


#1

Hi there, i have problem working with cargo. when i try to run cargo build. it’s not able to get dependencies from git due to squid proxy. help me to resolve this thank you.


#2

You can specify the http.proxy variable in a .cargo/config file which may help.


#3

Thank you very much,
but if the proxy contains credentials like username and password?


#4

http://login:pass@host:port”


#5

did this help??


#6

ya it is. just try it will work.


#7

Unforunately I am getting a SSL connect error :pensive:


#8

You probably need the “https” option instead of “http” then.


#9

I have the same problem from the point of view of a proxy. It’s my ISP, or is it something with settings?