Building Cargo port fails on FreeBSD i386


#1

===> Building for cargo-0.4.0.20150720
gmake[1]: Entering directory ‘/usr/ports/devel/cargo/work/cargo-9c5ffcb871’
/usr/local/bin/python2.7 src/etc/dl-snapshot.py i686-unknown-freebsd
Traceback (most recent call last):
File “src/etc/dl-snapshot.py”, line 57, in
raise Exception(“no snapshot for the triple ‘%s’” % triple)
Exception: no snapshot for the triple 'i686-unknown-freebsd’
Makefile:109: recipe for target ‘target/snapshot/cargo/bin/cargo’ failed
gmake[1]: *** [target/snapshot/cargo/bin/cargo] Error 1


#2

I haven’t tried a build recently, but 0.4.0 is quite old. The latest update on FreshPorts is from July 2015. Have you tried compiling from the latest source inside a jail to see what happens? There are some instructions at: https://github.com/rust-lang/cargo , and the ‘configure’ patch from FreeBSD Ports is at: https://svnweb.freebsd.org/ports/head/devel/cargo/files/patch-configure?revision=392600&view=markup and looks reasonably straightforward.


#3

I installed FreeBSD 10.2 i386 into a VM, pulled cargo 0.6.0 from Github, installed dependencies, and applied the patch - loads of Makefile errors, so not as straightforward as I thought… :weary: I’ll have another look at this over the weekend.


#4

Recent updates to the FreeBSD port for cargo note the lack of a bootstrap environment, which means that i386 builds aren’t working: https://svnweb.freebsd.org/ports?view=revision&revision=408340

On the plus side, amd64 has received cargo 0.8.0 last week and rust 1.6.0 in late January, so hopefully increasing interest and more frequent port updates for rust/cargo will encourage support for other FreeBSD hardware platforms.


#5

We hadn’t had a change in the snapshot in a very long time, and had to make a new one a week or two ago. So that’s probably the issue.


#6

I hope FreeBSD/arm support is coming… Can I help with it? Are there any resources for that?