Build Errors when using --enable-local-rust


#1

I’m trying to build rust 1.1.0 from source with gcc 4.8.1. I’m using --enable-local-rust because my build environment cannot curl out to the web to download a snapshot. I tried building with a prebuilt 1.1.0, but got these errors: https://gist.github.com/sdwilsh/236387171dad3a7e7a42. With 1.0.0, I got far fewer errors, but still encountered errors: https://gist.github.com/sdwilsh/08373a940e80f3e3d2c3. What version of Rust should I be using to build 1.1.0?


#2

You’d need a nightly that matches 1.1.0’s snapshot compiler’s version closely. This option is not (not yet at least) intended to work with stable releases of Rust.


#3

What’s the best way to determine what snapshot to use?


#4

Snapshot to use is recorded in src/snapshots.txt. For 1.1.0, it’s here.


#5

For anyone else hitting this for 1.1.0, the linux x86_64 binary for this is https://static.rust-lang.org/stage0-snapshots/rust-stage0-2015-04-27-857ef6e-linux-x86_64-94089740e48167c5975c92c139ae9c286764012f.tar.bz2

Thanks for the help everyone!