Bug in the editor when continuously deleting

Look at the GIF file. Press and hold the backspace key on Android may trigger the bug.

I can't reproduce on my android phone.

I was able to reproduce it on Android Firefox. It looks like the editor has some issue when you delete a whitespace character when there's another whitespace character to the right of the cursor. Instead of just deleting the character, it will also paste everything to the right of the cursor onto a new line. For example, if you try to delete the second character from the line

    type Error = ();

it turns into

   type Error = ();
  type Error = ();
1 Like

Does it reproduce on https://ace.c9.io? This is the editor we are using.

No, I tried both the front page and the Rust editor at Ace Kitchen Sink with the same code
I tried to find a change log to see if this is something that has been fixed in a recent version but I didn't see anything in the github releases that I found at least

Is this bug reproducible on desktop browsers?

Maybe I should tell you that my browser is Firefox Focus. Reproduced here: https://doc.rust-lang.org/stable/rust-by-example/flow_control/for.html

No, at least I wasn't able to do so on Firefox.

It may be related to keyword or scope.

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.