Application Stopped Building on Mac OS

I get the following error

error[E0463]: can't find crate for `serde_derive` which `built` depends on
2 | use built::Options;
  |     ^^^^^ can't find crate

error: aborting due to previous error

now, the interesting thing is that the application used to build without any problems, but for some reason it just stopped working.

Since I have no idea what caused this, I also have no idea how to solve it. Shouldn't I be able expect more or less the same result on each built given that the code is unchanged and I have the same Cargo.lock?

As you can see, building on Linux and Windows has worked without any issue at all, the problem is, for some reason, just isolated to Mac OS.

Any ideas or input is most welcome!

And just seconds after I posted this I found out a solution to the issue. Removing the saved cache in the GitHub workflow resolved the issue.

This topic was automatically closed 90 days after the last reply. We invite you to open a new topic if you have further questions or comments.