Add `#![feature(stdsimd)]` to the crate attributes to enable

hello everyone

i am trying to use blake 3, and i received this error when i run cargo build

   Compiling blake3 v0.1.4
error[E0658]: use of unstable library feature 'stdsimd'
   --> /home/oussama/.cargo/registry/src/github.com-1ecc6299db9ec823/blake3-0.1.4/src/platform.rs:266:12
    |
266 |         if is_x86_feature_detected!("avx512f") && is_x86_feature_detected!("avx512vl") {
    |            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    |
    = note: for more information, see https://github.com/rust-lang/rust/issues/27731
    = help: add `#![feature(stdsimd)]` to the crate attributes to enable
    = note: this error originates in a macro outside of the current crate (in Nightly builds, run with -Z external-macro-backtrace for more info)

error: aborting due to previous error

For more information about this error, try `rustc --explain E0658`.
error: could not compile `blake3`.

To learn more, run the command again with --verbose.

i tried to add #![feature(stdsimd)] to main.rs and lib.rs but the error still chown in both cases,

how can i resolve this error?

This error is in the code of blake3, not your project.

What rustc version are you using?

thanks @steveklabnik for your reply

i am using rustc 1.43.0-nightly (58b834344 2020-02-05)

for anyone else having this issue, i switched to stable and my problem is resolved.

1 Like

I just saw you opened an issues and the maintainers responded: https://github.com/BLAKE3-team/BLAKE3/issues/57

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.